summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorHubert Kario <hkario@redhat.com>2022-01-04 14:06:40 +0100
committerHubert Kario <hkario@redhat.com>2022-01-04 14:15:37 +0100
commit8eb07311c51f37f9ad01818c5d3b2808a43fcb7d (patch)
tree0bf3a09e14eafcc7571739da24c1c9c5a2b09693 /tox.ini
parent065b40c43e066de6df7f263ee43ade80d86d79f2 (diff)
downloadecdsa-8eb07311c51f37f9ad01818c5d3b2808a43fcb7d.tar.gz
Test on Python 3.10
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini20
1 files changed, 13 insertions, 7 deletions
diff --git a/tox.ini b/tox.ini
index 294eef3..7661d8c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
-envlist = py26, py27, py33, py34, py35, py36, py37, py38, py39, py, pypy, pypy3, gmpy2py27, gmpy2py39, gmpypy27, gmpypy39, codechecks
+envlist = py26, py27, py33, py34, py35, py36, py37, py38, py39, py310, py, pypy, pypy3, gmpy2py27, gmpy2py39, gmpy2py310, gmpypy27, gmpypy39, gmpypy310, codechecks
[testenv]
deps =
@@ -11,12 +11,12 @@ deps =
py{26}: unittest2
py{26}: hypothesis<3
py{34}: attrs<21
- py{26,27,34,35,36,37,38,39,py,py3}: pytest
- py{27,34,35,36,37,38,39,py,py3}: hypothesis
- gmpy2py{27,39}: gmpy2
- gmpypy{27,39}: gmpy
- gmpy{2py27,2py39,py27,py39}: pytest
- gmpy{2py27,2py39,py27,py39}: hypothesis
+ py{26,27,34,35,36,37,38,39,310,py,py3}: pytest
+ py{27,34,35,36,37,38,39,310,py,py3}: hypothesis
+ gmpy2py{27,39,310}: gmpy2
+ gmpypy{27,39,310}: gmpy
+ gmpy{2py27,2py39,2py310,py27,py39,py310}: pytest
+ gmpy{2py27,2py39,2py310,py27,py39,py310}: hypothesis
# six==1.9.0 comes from setup.py install_requires
py27_old_six: six==1.9.0
py27_old_six: pytest
@@ -50,12 +50,18 @@ basepython=python2.7
[testenv:gmpypy39]
basepython=python3.9
+[testenv:gmpypy310]
+basepython=python3.10
+
[testenv:gmpy2py27]
basepython=python2.7
[testenv:gmpy2py39]
basepython=python3.9
+[testenv:gmpy2py310]
+basepython=python3.10
+
[testenv:instrumental]
basepython = python2.7
deps =