summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorHubert Kario <hubert@kario.pl>2019-11-26 23:36:10 +0100
committerHubert Kario <hkario@redhat.com>2019-12-02 20:10:08 +0100
commitb1568d4a69c8868333e0de37365196079d535dfb (patch)
treefabce1bf529d880605c28d5225d77e90620c0ae0 /tox.ini
parent4403ec3cd2dec60537f5ea69fd902d1b5a6e4e61 (diff)
downloadecdsa-b1568d4a69c8868333e0de37365196079d535dfb.tar.gz
also allow the older gmpy
since on older distros like CentOS 6 there is python-gmpy but not python-gmpy2, support gmpy too
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini25
1 files changed, 18 insertions, 7 deletions
diff --git a/tox.ini b/tox.ini
index 08366c2..1416479 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
-envlist = py26, py27, py33, py34, py35, py36, py37, py38, py, pypy, pypy3, gmppy27, gmppy38
+envlist = py26, py27, py33, py34, py35, py36, py37, py38, py, pypy, pypy3, gmpy2py27, gmpy2py38, gmpypy27, gmpypy38
[testenv]
deps =
@@ -12,9 +12,10 @@ deps =
py{26}: hypothesis<3
py{26,27,34,35,36,37,38,py,py3}: pytest
py{27,34,35,36,37,38,py,py3}: hypothesis
- gmppy{27,38}: gmpy2
- gmppy{27,38}: pytest
- gmppy{27,38}: hypothesis
+ gmpy2py{27,38}: gmpy2
+ gmpypy{27,38}: gmpy
+ gmpy{2py27,2py38,py27,py38}: pytest
+ gmpy{2py27,2py38,py27,py38}: hypothesis
# six==1.9.0 comes from setup.py install_requires
py27_old_six: six==1.9.0
py27_old_six: pytest
@@ -28,10 +29,16 @@ commands = coverage run --branch -m pytest {posargs:src/ecdsa}
[testenv:py27_old_six]
basepython = python2.7
-[testenv:gmppy27]
+[testenv:gmpypy27]
basepython=python2.7
-[testenv:gmppy38]
+[testenv:gmpypy38]
+basepython=python3.8
+
+[testenv:gmpy2py27]
+basepython=python2.7
+
+[testenv:gmpy2py38]
basepython=python3.8
[testenv:coverage]
@@ -41,7 +48,11 @@ commands = coverage run --branch -m pytest --hypothesis-show-statistics {posargs
[testenv:speed]
commands = {envpython} speed.py
-[testenv:speedgmp2]
+[testenv:speedgmpy]
+deps = gmpy
+commands = {envpython} speed.py
+
+[testenv:speedgmpy2]
deps = gmpy2
commands = {envpython} speed.py