summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorBrian Warner <warner@lothar.com>2016-11-18 11:40:28 -0800
committerBrian Warner <warner@lothar.com>2016-11-18 11:43:21 -0800
commitc877639b55fa0651ecbbcc8b0d01627d25e5e8c3 (patch)
treeb011b575425a36a35bf24fa02ca20970fbce9426 /tox.ini
parent187e1b52f8b0b08b4b388dbc722de785fbf164d2 (diff)
downloadecdsa-c877639b55fa0651ecbbcc8b0d01627d25e5e8c3.tar.gz
tox: update code-checks to use flake8
Most of the warnings are disabled for now, there's lots of whitespace issues to fix.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini24
1 files changed, 22 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 0e3cea2..1aab69a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -17,5 +17,25 @@ commands = coverage run -m pytest {posargs:src/ecdsa}
commands = {envpython} speed.py
[testenv:codechecks]
-deps = pyflakes
-commands = pyflakes setup.py speed.py src
+basepython = python3.5
+deps =
+ pyflakes
+ flake8
+commands =
+ flake8 setup.py speed.py src
+
+
+[flake8]
+exclude = src/ecdsa/test*.py
+# We're just getting started. For now, ignore the following problems:
+# E111: indentation is not a multiple of four
+# E114: indentation is not a multiple of four (comment)
+# E226: missing whitespace around arithmetic operator
+# E231: missing whitespace after ','
+# E266: too many leading '#' for block comment
+# E302: expected 2 blank lines, found 1
+# E305: expected 2 blank lines after class or function defintion, found 1
+# E501: line too long
+# E502: the backslash is redundant between brackets
+# W391: blank line at end of file
+ignore = E111,E114,E226,E231,E266,E302,E305,E501,E502,W391