summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2014-09-26 09:09:29 +1200
committerRobert Collins <robertc@robertcollins.net>2014-09-26 09:09:29 +1200
commitd35c2d3cf1628c5f76d1f53a34a9cff1218d4ff7 (patch)
tree4b12198d102b52a9377f0d63d5adaf157bad0597
parentcfe7eab29c2c305b3bff702e3e268292cb600a1b (diff)
downloadfixtures-d35c2d3cf1628c5f76d1f53a34a9cff1218d4ff7.tar.gz
Release 0.3.17.
-rw-r--r--HACKING3
-rw-r--r--NEWS3
-rw-r--r--fixtures/__init__.py29
3 files changed, 12 insertions, 23 deletions
diff --git a/HACKING b/HACKING
index 386d3ce..b27e72b 100644
--- a/HACKING
+++ b/HACKING
@@ -36,8 +36,7 @@ the fixtures __init__.py.
Releasing
+++++++++
-1. Update the version number in __init__.py and setup.py and add a version to
- NEWS.
+1. Update the version number in __init__.py and add a version to NEWS.
1. Upload to pypi, signed.
diff --git a/NEWS b/NEWS
index 7f00485..d3f26ff 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,9 @@ fixtures release notes
NEXT
~~~~
+0.3.17
+~~~~~~
+
* FakeLogger now supports the ``datefmt`` parameter.
(Sean Dague)
diff --git a/fixtures/__init__.py b/fixtures/__init__.py
index bfbd3dd..cc3ca6e 100644
--- a/fixtures/__init__.py
+++ b/fixtures/__init__.py
@@ -36,7 +36,14 @@ Most users will want to look at TestWithFixtures and Fixture, to start with.
# established at this point, and setup.py will use a version of next-$(revno).
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 3, 16, 'final', 0)
+
+# Uncomment when pbr 0.11 is released.
+#import pbr.version
+#_version = pbr.version.VersionInfo('fixtures').semantic_version()
+#__version__ = _version.version_tuple()
+#version = _version.release_string()
+__version__ = (0, 3, 17, 'final', 0)
+
__all__ = [
'ByteStream',
@@ -67,8 +74,6 @@ __all__ = [
]
-import pbr.version
-
from fixtures.fixture import (
Fixture,
FunctionFixture,
@@ -97,24 +102,6 @@ from fixtures._fixtures import (
)
from fixtures.testcase import TestWithFixtures
-# same format as sys.version_info: "A tuple containing the five components of
-# the version number: major, minor, micro, releaselevel, and serial. All
-# values except releaselevel are integers; the release level is 'alpha',
-# 'beta', 'candidate', or 'final'. The version_info value corresponding to the
-# Python version 2.0 is (2, 0, 0, 'final', 0)." Additionally we use a
-# releaselevel of 'dev' for unreleased under-development code.
-#
-# If the releaselevel is 'alpha' then the major/minor/micro components are not
-# established at this point, and setup.py will use a version of next-$(revno).
-# If the releaselevel is 'final', then the tarball will be major.minor.micro.
-# Otherwise it is major.minor.micro~$(revno).
-
-# Uncomment when pbr 0.11 is released.
-#_version = pbr.version.VersionInfo('fixtures').semantic_version()
-#__version__ = _version.version_tuple()
-#version = _version.release_string()
-__version__ = (0, 3, 17, 'alpha', 0)
-
def test_suite():
import fixtures.tests