summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2010-08-15 21:01:23 +1200
committerRobert Collins <robertc@robertcollins.net>2010-08-15 21:01:23 +1200
commitae179f1966ef3aaf6ec49cc819bffb7f4b7fd757 (patch)
tree235184e648b09dd0b296616c39a76e717dba60de /Makefile
downloadfixtures-ae179f1966ef3aaf6ec49cc819bffb7f4b7fd757.tar.gz
First draft - 0.1.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..7f8fafc
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,19 @@
+PYTHONPATH:=$(shell pwd)/lib:${PYTHONPATH}
+PYTHON ?= python
+
+all: check
+
+check:
+ PYTHONPATH=$(PYTHONPATH) $(PYTHON) -m testtools.run \
+ fixtures.test_suite
+
+clean:
+ find . -name '*.pyc' -print0 | xargs -0 rm -f
+
+TAGS: lib/fixtures/*.py lib/fixtures/tests/*.py
+ ctags -e -R lib/fixtures/
+
+tags: lib/fixtures/*.py lib/fixtures/tests/*.py
+ ctags -R lib/fixtures/
+
+.PHONY: all check clean