summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTerence Honles <terence@honles.com>2012-05-07 15:13:26 -0700
committerTerence Honles <terence@honles.com>2012-05-07 15:16:23 -0700
commit2f0e5b5f1a5ee11a958acc8acdc47b187a76ec1b (patch)
treefbf7776931a7902505e84d9dfb7a038e0c667a0d
parent6b72a1437bba484b9a7c4ed2c8fbb94f085c9247 (diff)
downloadfusepy-2f0e5b5f1a5ee11a958acc8acdc47b187a76ec1b.tar.gz
updating readme/setup + pointing to new urls
- fixed 1 missing utf-8 decode
-rw-r--r--README.rst29
-rw-r--r--fuse.py12
-rwxr-xr-xsetup.py5
3 files changed, 26 insertions, 20 deletions
diff --git a/README.rst b/README.rst
index beff1d8..cbdd977 100644
--- a/README.rst
+++ b/README.rst
@@ -4,16 +4,13 @@ fusepy
``fusepy`` is a Python module that provides a simple interface to FUSE_ and
MacFUSE_. It's just one file and is implemented using ctypes.
-The official version of ``fusepy`` is hosted on `Google Code`_, but was split
-into 3 seperate files: fuse24.py, fuse.py, and fuse3.py. These versions were
-for <Python2.5, <Python3.x, and Python3.x respectively. Unfortunately they were
-not all maintained, and installing the package in Python3 did not work.
+The original version of ``fusepy`` was hosted on `Google Code`_, but is now
+`officially hosted on GitHub`_.
-This repo mereges bits from all 3 files and combines them into one file. The
-file is written in 2x syntax, but trying to pay attention to bytes and other
-changes 3x would care about. The only incompatible changes between 2x and 3x
-are the change in syntax for number literals and exceptions. These issues are
-fixed using the 2to3 tool when installing the package, or runnning::
+``fusepy`` is written in 2x syntax, but trying to pay attention to bytes and
+other changes 3x would care about. The only incompatible changes between 2x and
+3x are the change in syntax for number literals and exceptions. These issues
+are fixed using the 2to3 tool when installing the package, or runnning::
2to3 -f numliterals -f except -w fuse.py
@@ -39,9 +36,13 @@ fusepy requires FUSE 2.6 (or later) and runs on:
.. _FUSE: http://fuse.sourceforge.net/
.. _MacFUSE: http://code.google.com/p/macfuse/
.. _`Google Code`: http://code.google.com/p/fusepy/
-.. _memory: http://github.com/terencehonles/fusepy/tree/master/examples/memory.py
-.. _loopback: http://github.com/terencehonles/fusepy/tree/master/examples/loopback.py
-.. _context: http://github.com/terencehonles/fusepy/tree/master/examples/context.py
-.. _sftp: http://github.com/terencehonles/fusepy/tree/master/examples/sftp.py
+
+.. _officially hosted on GitHub: source_
.. _download: https://github.com/terencehonles/fusepy/zipball/master
-.. _source: http://github.com/terencehonles/fusepy/tree/master/
+.. _source: http://github.com/terencehonles/fusepy
+
+.. examples
+.. _memory: http://github.com/terencehonles/fusepy/blob/master/examples/memory.py
+.. _loopback: http://github.com/terencehonles/fusepy/blob/master/examples/loopback.py
+.. _context: http://github.com/terencehonles/fusepy/blob/master/examples/context.py
+.. _sftp: http://github.com/terencehonles/fusepy/blob/master/examples/sftp.py
diff --git a/fuse.py b/fuse.py
index 2cea0c6..3b91740 100644
--- a/fuse.py
+++ b/fuse.py
@@ -1,4 +1,5 @@
-# Copyright (c) 2008 Giorgos Verigakis <verigak@gmail.com>
+# Copyright (c) 2012 Terence Honles <terence@honles.com> (maintainer)
+# Copyright (c) 2008 Giorgos Verigakis <verigak@gmail.com> (author)
#
# Permission to use, copy, modify, and distribute this software for any
# purpose with or without fee is hereby granted, provided that the above
@@ -40,7 +41,9 @@ except ImportError:
newfunc.keywords = keywords
return newfunc
-if not hasattr(__builtins__, 'basestring'):
+try:
+ basestring
+except NameError:
basestring = str
class c_timespec(Structure):
@@ -543,10 +546,9 @@ class FUSE(object):
return retsize
def listxattr(self, path, namebuf, size):
- ret = '\x00'.join(self.operations('listxattr', path) or '') \
- .encode(self.encoding)
+ attrs = self.operations('listxattr', path.decode(self.encoding)) or ''
- buf = create_string_buffer(ret)
+ buf = create_string_buffer('\x00'.join(attrs).encode(self.encoding))
bufsize = len(buf)
if namebuf:
if bufsize > size: return -ERANGE
diff --git a/setup.py b/setup.py
index 326df55..e849f49 100755
--- a/setup.py
+++ b/setup.py
@@ -13,14 +13,17 @@ with open('README') as readme:
setup(
name = 'fusepy',
- version = '1.2',
+ version = '2.0',
description = 'Simple ctypes bindings for FUSE',
long_description = documentation,
author = 'Giorgos Verigakis',
author_email = 'verigak@gmail.com',
+ maintainer = 'Terence Honles',
+ maintainer_email = 'terence@honles.com',
license = 'ISC',
py_modules=['fuse'],
+ url = 'http://github.com/terencehonles/fusepy',
use_2to3 = True,
# only use the following fixers (everything else is already compatible)