summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-04-05 19:10:41 -0400
committerMonty Taylor <mordred@inaugust.com>2013-04-08 12:31:53 -0400
commit855b217f6dac1fd6a613ba8bfda120f8c96734b8 (patch)
treee75ce4ac6f49ffe0b6006b3c14b1e25a7a9c1b5a /setup.py
parentb6097dc7ed885ff7241ca90f95246c66dbe7cf10 (diff)
downloadgear-855b217f6dac1fd6a613ba8bfda120f8c96734b8.tar.gz
Add pbr-based setup.
Change-Id: I8ff06c6711e1d9f5bf4d1278f37d4e2f7f799e3d
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..59a0090
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+import setuptools
+
+setuptools.setup(
+ setup_requires=['d2to1', 'pbr'],
+ d2to1=True)