summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMohammed Naser <mnaser@vexxhost.com>2019-10-14 12:37:47 -0400
committerMohammed Naser <mnaser@vexxhost.com>2019-10-14 12:47:52 -0400
commita4449758bfcedd99be15ebbdb212746e4e2356ee (patch)
treecb8a6d1240f5c9cd499ebe1dd8caa94670d5b356 /tox.ini
parent483ab492a86907b4509b154d978af62266e814c8 (diff)
downloadgear-a4449758bfcedd99be15ebbdb212746e4e2356ee.tar.gz
Fix documentation builds
This patch does a few things to fix the documentation builds for this project - Move requirements to doc/requirements.txt for building docs to avoid installing extra dependencies. - Bump sphinx version to a newer release which is compatible with sphinxcontrib-programoutput - Remove default theme option to use the latest Sphinx theme that is shipped directly from upstream. - Bumped basepython for documentation jobs to Python 3. These are all squashed because the job is currently broken. Change-Id: Ib998923a5daaa5e9d3ddc748b76b6304e5c39b22
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini6
1 files changed, 5 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 9feb228..5984ff7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -33,7 +33,11 @@ show-source = true
ignore = E123,E125,E129,H
[testenv:docs]
-commands = python setup.py build_sphinx
+basepython = python3
+deps =
+ -r{toxinidir}/doc/requirements.txt
+commands =
+ sphinx-build -E -W -d doc/build/doctrees -b html doc/source/ doc/build/html
[testenv:bindep]
# Do not install any requirements. We want this to be fast and work even if