summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2017-09-28 10:52:51 +0200
committerSebastian Thiel <byronimo@gmail.com>2017-09-28 11:01:55 +0200
commit0d5062eac9d03ea63975446439600e63feb83163 (patch)
tree15b819479f9c24d10da3516b994357e93d3251fd
parent7f216d9c8954182e978046384e5491840f936216 (diff)
downloadgitdb-0d5062eac9d03ea63975446439600e63feb83163.tar.gz
Upgrade makefile2.0.3
-rw-r--r--Makefile16
-rw-r--r--gitdb/__init__.py2
m---------gitdb/ext/smmap0
-rwxr-xr-xsetup.py2
4 files changed, 17 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index c6c159b..8cb323e 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,21 @@ SETUP = $(PYTHON) setup.py
TESTRUNNER = $(shell which nosetests)
TESTFLAGS =
-all: build
+all::
+ @grep -Ee '^[a-z].*:' Makefile | cut -d: -f1 | grep -vF all
+
+release:: clean
+ # Check if latest tag is the current head we're releasing
+ echo "Latest tag = $$(git tag | sort -nr | head -n1)"
+ echo "HEAD SHA = $$(git rev-parse head)"
+ echo "Latest tag SHA = $$(git tag | sort -nr | head -n1 | xargs git rev-parse)"
+ @test "$$(git rev-parse head)" = "$$(git tag | sort -nr | head -n1 | xargs git rev-parse)"
+ make force_release
+
+force_release:: clean
+ git push --tags
+ python3 setup.py sdist bdist_wheel
+ twine upload -s -i byronimo@gmail.com dist/*
doc::
make -C doc/ html
diff --git a/gitdb/__init__.py b/gitdb/__init__.py
index bfa083b..e184e4b 100644
--- a/gitdb/__init__.py
+++ b/gitdb/__init__.py
@@ -29,7 +29,7 @@ _init_externals()
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (2, 0, 0)
+version_info = (2, 0, 3)
__version__ = '.'.join(str(i) for i in version_info)
diff --git a/gitdb/ext/smmap b/gitdb/ext/smmap
-Subproject ac5df7061ee11232346b3d0eb3aa5b43eebc847
+Subproject 91d506e120d4a0f98cbef202325e301c632445c
diff --git a/setup.py b/setup.py
index f7e3761..4bff11d 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ from setuptools import setup
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (2, 0, 0)
+version_info = (2, 0, 3)
__version__ = '.'.join(str(i) for i in version_info)
setup(