summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHarmon <Harmon758@gmail.com>2020-02-22 16:25:56 -0600
committerHarmon <Harmon758@gmail.com>2020-02-22 16:25:56 -0600
commit02de02cbd938015ff6ba3e668da4e641fdd74c4a (patch)
tree1f32af1057d2d86db73977a4d623b4ae88562002 /setup.py
parent5699c137e2078be52392b69a6d1bae65e9464cef (diff)
downloadgitdb-02de02cbd938015ff6ba3e668da4e641fdd74c4a.tar.gz
Restrict smmap2 version to <3
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a66b229..49cbf36 100755
--- a/setup.py
+++ b/setup.py
@@ -20,7 +20,7 @@ setup(
packages=('gitdb', 'gitdb.db', 'gitdb.utils', 'gitdb.test'),
license="BSD License",
zip_safe=False,
- install_requires=['smmap2 >= 2.0.0'],
+ install_requires=['smmap2>=2,<3'],
long_description="""GitDB is a pure-Python git object database""",
python_requires='>=3.4',
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers