summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2014-11-13 09:00:44 +0100
committerSebastian Thiel <byronimo@gmail.com>2014-11-13 09:00:44 +0100
commit85dde34bc724570617f3df1cdc40ba1b0942c77e (patch)
tree4d60b1dd22a5c78688c437dabe68381bb11c4b1f /setup.py
parent81707c606b88e971cc359e3e9f3abeeea2204860 (diff)
downloadgitdb-85dde34bc724570617f3df1cdc40ba1b0942c77e.tar.gz
Minor adjustments to adapt to changes in async (due to be removed anyway)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py35
1 files changed, 26 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 6dd4fa4..6393704 100755
--- a/setup.py
+++ b/setup.py
@@ -73,7 +73,7 @@ if setuptools_build_py_module:
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (0, 5, 4)
+version_info = (0, 5, 5)
__version__ = '.'.join(str(i) for i in version_info)
setup(cmdclass={'build_ext':build_ext_nofail},
@@ -88,15 +88,32 @@ setup(cmdclass={'build_ext':build_ext_nofail},
ext_modules=[Extension('gitdb._perf', ['gitdb/_fun.c', 'gitdb/_delta_apply.c'], include_dirs=['gitdb'])],
license = "BSD License",
zip_safe=False,
- requires=('async (>=0.6.1)', 'smmap (>=0.8.0)'),
+ requires=('async (>=0.6.2)', 'smmap (>=0.8.3)'),
install_requires=('async >= 0.6.1', 'smmap >= 0.8.0'),
long_description = """GitDB is a pure-Python git object database""",
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=[
- # Specify the Python versions you support here. In particular, ensure
- # that you indicate whether you support Python 2, Python 3 or both.
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- ],
- )
+ # Picked from
+ # http://pypi.python.org/pypi?:action=list_classifiers
+ #"Development Status :: 1 - Planning",
+ #"Development Status :: 2 - Pre-Alpha",
+ #"Development Status :: 3 - Alpha",
+ # "Development Status :: 4 - Beta",
+ "Development Status :: 5 - Production/Stable",
+ #"Development Status :: 6 - Mature",
+ #"Development Status :: 7 - Inactive",
+ "Environment :: Console",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Operating System :: POSIX",
+ "Operating System :: Microsoft :: Windows",
+ "Operating System :: MacOS :: MacOS X",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ ],)