summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2020-02-15 10:01:11 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2020-02-15 10:01:11 +0800
commitdf73d7f6874ff11be1b09f65c8dc425671bb924e (patch)
treeb336f9d34ea14784a9735ce1f9bd6046945fff4d /setup.py
parent2f9a799a6c9d125012bb09473bbfe6110f2a7391 (diff)
downloadgitdb-df73d7f6874ff11be1b09f65c8dc425671bb924e.tar.gz
Release 3.0.03.0.0
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 6a2174f..a66267e 100755
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,7 @@ from setuptools import setup
__author__ = "Sebastian Thiel"
__contact__ = "byronimo@gmail.com"
__homepage__ = "https://github.com/gitpython-developers/gitdb"
-version_info = (2, 0, 6)
+version_info = (3, 0, 0)
__version__ = '.'.join(str(i) for i in version_info)
setup(
@@ -22,7 +22,7 @@ setup(
zip_safe=False,
install_requires=['smmap2 >= 2.0.0'],
long_description="""GitDB is a pure-Python git object database""",
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=3.4',
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=[
"Development Status :: 5 - Production/Stable",
@@ -34,11 +34,10 @@ setup(
"Operating System :: Microsoft :: Windows",
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7"
]
)