summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-09-28 17:43:34 -0500
committerJason Madden <jamadden@gmail.com>2021-10-12 08:53:56 -0500
commit1921580ff0e687e9f7e9ecb320b177f9cbc1054b (patch)
tree08c34a9cfd68034bd778de12f36244aa31282cfe /setup.py
parente960906edc537582937201da30e1b1bd428401af (diff)
downloadgreenlet-1921580ff0e687e9f7e9ecb320b177f9cbc1054b.tar.gz
Drop Python 2.7 on Windows; the compiler is far too old.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 39fe0d1..03f7390 100755
--- a/setup.py
+++ b/setup.py
@@ -22,6 +22,9 @@ if ((sys.platform == "openbsd4" and os.uname()[-1] == "i386")
or (sys.platform == "linux" and platform.machine() == "ppc")):
os.environ["CFLAGS"] = ("%s %s" % (os.environ.get("CFLAGS", ""), "-Os")).lstrip()
+if (sys.platform == 'darwin'):
+ # The clang compiler doesn't use --std=c++11 by default
+ os.environ["CFLAGS"] = ("%s %s" % (os.environ.get("CFLAGS", ""), "--std=gnu++11")).lstrip()
def readfile(filename):
with open(filename, 'r') as f: