summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-10-28 08:25:59 -0500
committerJason Madden <jamadden@gmail.com>2021-10-28 08:25:59 -0500
commit494ab102e570b29fd5e6eb0f7b516aae3fde2909 (patch)
treee0266f0ce043afa274b48d8700bdbf200852660d /setup.py
parente04267fe21ef49991a1295837c74ec3a40f101b8 (diff)
downloadgreenlet-494ab102e570b29fd5e6eb0f7b516aae3fde2909.tar.gz
Add version pin for docutils on Python 2.7.
docutils 0.18 breaks old sphinx with 'TypeError: argument to reversed() must be a sequence' because node.traverse returns a generator.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2d901c9..66af1c5 100755
--- a/setup.py
+++ b/setup.py
@@ -176,6 +176,9 @@ setup(
extras_require={
'docs': [
'Sphinx',
+ # 0.18b1 breaks sphinx 1.8.5 which is the latest version that runs
+ # on Python 2. The version pin sphinx itself contains isn't specific enough.
+ 'docutils < 0.18; python_version < "3"',
],
'test': [
'objgraph',