summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-10-06 07:36:36 -0500
committerJason Madden <jamadden@gmail.com>2021-10-12 08:53:58 -0500
commit5bf7906637a74d0212073c70e7e96a3330edc97b (patch)
tree8b8ea62eab0fbf0d325872e2540e748d6fc2bf9b /setup.py
parente25aea0b3c7480f0708407eb59c679f1e9144362 (diff)
downloadgreenlet-5bf7906637a74d0212073c70e7e96a3330edc97b.tar.gz
Implement cleanup using the thread dictionary on platforms that require it.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index bcb02c5..508e821 100755
--- a/setup.py
+++ b/setup.py
@@ -39,7 +39,7 @@ if sys.platform == 'darwin':
def readfile(filename):
- with open(filename, 'r') as f:
+ with open(filename, 'r') as f: # pylint:disable=unspecified-encoding
return f.read()
GREENLET_SRC_DIR = 'src/greenlet/'
@@ -53,6 +53,9 @@ GREENLET_PLATFORM_DIR = GREENLET_SRC_DIR + 'platform/'
def _find_platform_headers():
return glob.glob(GREENLET_PLATFORM_DIR + "switch_*.h")
+def _find_impl_headers():
+ return glob.glob(GREENLET_SRC_DIR + "*.hpp")
+
if hasattr(sys, "pypy_version_info"):
ext_modules = []
headers = []
@@ -82,7 +85,7 @@ else:
depends=[
GREENLET_HEADER,
GREENLET_SRC_DIR + 'slp_platformselect.h',
- ] + _find_platform_headers()
+ ] + _find_platform_headers() + _find_impl_headers()
),
# Test extensions.
#
@@ -113,7 +116,7 @@ else:
def get_greenlet_version():
- with open('src/greenlet/__init__.py') as f:
+ with open('src/greenlet/__init__.py') as f: # pylint:disable=unspecified-encoding
looking_for = '__version__ = \''
for line in f:
if line.startswith(looking_for):