summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2022-10-30 07:40:37 -0500
committerJason Madden <jamadden@gmail.com>2022-10-30 07:40:37 -0500
commit8956216492296b3ec9d3238328d94517daeffca4 (patch)
tree8a532d4c98391611efecd16c394d85e17710f748 /setup.py
parenta0a6d5bfc129c5ccaaf21c4100802ff53293ac5d (diff)
downloadgreenlet-8956216492296b3ec9d3238328d94517daeffca4.tar.gz
Win32: Using /EHr, annotate inner_bootstrap again as noexcept to try to force the termination that we otheriwse can't seem to get.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4c2e728..a4248af 100755
--- a/setup.py
+++ b/setup.py
@@ -55,7 +55,7 @@ elif is_win and "MSC" in platform.python_compiler():
# with it. Leaving off the "c" should just result in slower, safer code.
# Other options:
# "r" == Always generate standard confirming checks for noexcept blocks, terminating
- # if violated.
+ # if violated. IMPORTANT: We rely on this.
# See https://docs.microsoft.com/en-us/cpp/build/reference/eh-exception-handling-model?view=msvc-160
handler = "/EHsr"
cpp_compile_args.append(handler)