summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-10-19 17:11:28 -0500
committerJason Madden <jamadden@gmail.com>2021-10-19 17:11:28 -0500
commita7965221757261d03574c19d73b6d8cce76e6c71 (patch)
tree035bf33c666087a0c0580adee4ff7d594481319f /setup.py
parent8439114b2e22f3d2f108dfa619b9f00cb903ab74 (diff)
downloadgreenlet-a7965221757261d03574c19d73b6d8cce76e6c71.tar.gz
Add leakchecks to the actual test cases themselves.
Instead of relying on zope.testrunner, which is meant to only work in a Py_DEBUG build. This denotes several test cases that are actually leaking by these measures.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0c111ba..2d901c9 100755
--- a/setup.py
+++ b/setup.py
@@ -178,6 +178,7 @@ setup(
'Sphinx',
],
'test': [
+ 'objgraph',
],
},
python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*",