summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2022-11-06 12:30:41 -0600
committerJason Madden <jamadden@gmail.com>2022-11-07 05:23:45 -0600
commitaa6f2515b2fefced69be933952bd1f3319d0de58 (patch)
tree5925396859a467e2b8f0d98b60fdb4694476db25 /setup.py
parent7389976dc748677dd4fce535b91ef07e4387c1d6 (diff)
downloadgreenlet-aa6f2515b2fefced69be933952bd1f3319d0de58.tar.gz
Python 3.11: Fix a memory leak switching to greenlets.
This leak was present in the original implementation of Python 3.11 support (#306) Fixes #328 and fixes https://github.com/gevent/gevent/issues/1924 ; I have run gevent's test suite locally on 3.11 with this fix without seeing any regressions.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6c3984c..f1931fd 100755
--- a/setup.py
+++ b/setup.py
@@ -226,7 +226,8 @@ setup(
],
'test': [
'objgraph',
- 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"',
+ 'faulthandler; python_version == "2.7" and platform_python_implementation == "CPython"',
+ 'psutil',
],
},
python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*",