summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2020-10-01 05:55:22 -0500
committerJason Madden <jamadden@gmail.com>2020-10-01 06:00:15 -0500
commitbb249b6ca6a252682944581b5231107d367ba6da (patch)
treee14bf74dbb8b621cde986a735987c335736b6feb /setup.py
parent80c92d3b946daf3062f687c1f72a620956532825 (diff)
downloadgreenlet-bb249b6ca6a252682944581b5231107d367ba6da.tar.gz
Officially drop support for 2.4/5/6 and 3.0/1/2/3/4.issue186
Change the classifiers, update the version number, remove those versions from CI. This does not yet make any code changes. Using 3.4 as the cutoff point because that's where the biggest drop in usage comes; it's also no longer supported by gevent or eventlet. Fixes #186
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 19df822..77d7978 100755
--- a/setup.py
+++ b/setup.py
@@ -65,7 +65,7 @@ else:
setup(
name="greenlet",
- version='0.4.17',
+ version='1.0.0.dev0',
description='Lightweight in-process concurrent programming',
long_description=readfile("README.rst"),
url="https://github.com/python-greenlet/greenlet",
@@ -86,13 +86,8 @@ setup(
'Programming Language :: C',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.4',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
@@ -106,6 +101,7 @@ setup(
'Sphinx',
]
},
+ python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*",
# XXX: This is deprecated. appveyor.yml still uses it though.
test_suite='tests.test_collector',
zip_safe=False,