summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-10-28 18:05:41 -0500
committerJason Madden <jamadden@gmail.com>2021-10-28 18:05:41 -0500
commitbcf1463d47bd074a5c03f8b2db51ef15ea125a0c (patch)
tree195f18bc30d7348350fc91237d4cd40cd0147dcf /setup.py
parent83a1093f0459e88ce470ac0e2fcbc01f48ec75c5 (diff)
downloadgreenlet-bcf1463d47bd074a5c03f8b2db51ef15ea125a0c.tar.gz
Can't use /MDd because we would need the Python debug libs.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 157ac16..214c795 100755
--- a/setup.py
+++ b/setup.py
@@ -58,13 +58,14 @@ elif sys.platform == 'win32':
cpp_compile_args.append('/Od')
# enable assertions
cpp_compile_args.append('/UNDEBUG')
- # enable more compile-time warnings
- cpp_compile_args.append('/Wall')
- # link with the debug C runtime
- cpp_compile_args.append('/MDd')
+ # enable more compile-time warnings. /Wall produces a mountain of output.
+ cpp_compile_args.append('/W4')
+ # link with the debug C runtime...except we can't because we need
+ # the Python debug lib too, and they're not around by default
+ # cpp_compile_args.append('/MDd')
# Support fiber-safe thread-local storage: "the compiler mustn't
# cache the address of the TLS array, or optimize it as a common
- # subexpression across a function call" This would probably solve
+ # subexpression across a function call." This would probably solve
# some of the issues we had with MSVC caching the thread local
# variables on the stack, leading to having to split some
# functions up.