summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2021-11-03 11:09:02 -0500
committerJason Madden <jamadden@gmail.com>2021-11-03 11:09:02 -0500
commitf1345cb85ec8be4557b3677222cb9dab2848ef35 (patch)
treeee7a695a7993a1ad3c283d85efb46cfbfde16302 /setup.py
parent1865d4ff1007e17ef7a059eace8b2d06fb11ddd0 (diff)
downloadgreenlet-f1345cb85ec8be4557b3677222cb9dab2848ef35.tar.gz
Start work on making PyGreenlet opaque. First part of the conversion: the exception state.
Also fix PyGreenlet_New to use green_new and green_init; before, it was bypassing a lot of initialization code, and in this case that made things crash.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 488f7fe..4a6efe4 100755
--- a/setup.py
+++ b/setup.py
@@ -116,7 +116,9 @@ else:
ext_modules = [
Extension(
name='greenlet._greenlet',
- sources=[GREENLET_SRC_DIR + 'greenlet.cpp'],
+ sources=[
+ GREENLET_SRC_DIR + 'greenlet.cpp',
+ ],
language='c++',
extra_objects=extra_objects,
extra_compile_args=global_compile_args + main_compile_args + cpp_compile_args,