summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2020-09-30 16:02:43 -0500
committerJason Madden <jamadden@gmail.com>2020-09-30 16:02:43 -0500
commitf245e9c203f1b90bbebc6803966a87cc5fcbc49d (patch)
tree7bcee991b34654bc34cf3f02f44a81f50a48e286 /setup.py
parent4650c20cbba148fa480e9ff71a7cf209e8eb85b7 (diff)
downloadgreenlet-f245e9c203f1b90bbebc6803966a87cc5fcbc49d.tar.gz
Drop 3.0, 3.1 and 3.2; they're no longer supported by setuptools.publish-changes
And restore the test_suite argument as that's currently required on Appveyor, even though its deprecated.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 222f0d2..19df822 100755
--- a/setup.py
+++ b/setup.py
@@ -91,9 +91,6 @@ setup(
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.0',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
@@ -108,6 +105,8 @@ setup(
'docs': [
'Sphinx',
]
- }
-
+ },
+ # XXX: This is deprecated. appveyor.yml still uses it though.
+ test_suite='tests.test_collector',
+ zip_safe=False,
)