summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstaticdev <staticdev-support@proton.me>2022-12-21 20:59:30 +0000
committerGitHub <noreply@github.com>2022-12-21 20:59:30 +0000
commit98390f5fde8f904f16a4e290a2aabed80d0951dc (patch)
treed267b4abc6784d79b09dbc98dae206a67f896aa5
parentf9add587e80733b043f7ccd27b7a85a5f9e0e27d (diff)
parentdf69a0549901043a1958dac9b14ad7de03dcae0e (diff)
downloadisort-5.11.4.tar.gz
Merge pull request #2059 from PyCQA/version/5.11.45.11.4
Bump version 5.11.4
-rw-r--r--CHANGELOG.md7
-rw-r--r--docs/configuration/pre-commit.md4
-rw-r--r--isort/_version.py2
-rw-r--r--pyproject.toml2
4 files changed, 11 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 3012dfbd..9e5cee44 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,13 @@ Changelog
NOTE: isort follows the [semver](https://semver.org/) versioning standard.
Find out more about isort's release policy [here](https://pycqa.github.io/isort/docs/major_releases/release_policy).
+### 5.11.4 December 21 2022
+
+ - Fixed #2038 (again): stop installing documentation files to top-level site-packages (#2057) @mgorny
+ - CI: only run release workflows for upstream (#2052) @hugovk
+ - Tests: remove obsolete toml import from the test suite (#1978) @mgorny
+ - CI: bump Poetry 1.3.1 (#2058) @staticdev
+
### 5.11.3 December 16 2022
- Fixed #2007: settings for py3.11 (#2040) @staticdev
diff --git a/docs/configuration/pre-commit.md b/docs/configuration/pre-commit.md
index e8309543..1281e6e5 100644
--- a/docs/configuration/pre-commit.md
+++ b/docs/configuration/pre-commit.md
@@ -9,7 +9,7 @@ To use isort's official pre-commit integration add the following config:
```yaml
- repo: https://github.com/pycqa/isort
- rev: 5.11.3
+ rev: 5.11.4
hooks:
- id: isort
name: isort (python)
@@ -20,7 +20,7 @@ over different file types (ex: python vs cython vs pyi) you can do so with the f
```yaml
- repo: https://github.com/pycqa/isort
- rev: 5.11.3
+ rev: 5.11.4
hooks:
- id: isort
name: isort (python)
diff --git a/isort/_version.py b/isort/_version.py
index 5e263ef9..941c1bcc 100644
--- a/isort/_version.py
+++ b/isort/_version.py
@@ -1 +1 @@
-__version__ = "5.11.3"
+__version__ = "5.11.4"
diff --git a/pyproject.toml b/pyproject.toml
index b0608a58..744d444f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,7 +3,7 @@ line-length = 100
[tool.poetry]
name = "isort"
-version = "5.11.3"
+version = "5.11.4"
description = "A Python utility / library to sort Python imports."
authors = ["Timothy Crosley <timothy.crosley@gmail.com>"]
license = "MIT"