summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorBrad Solomon <bsolomon@protonmail.com>2020-05-14 09:22:21 -0400
committerBrad Solomon <brsolomon@deloitte.com>2020-05-14 09:23:18 -0400
commitd91f45286ca8f7a05e17ff0edc20f35d54a80c7d (patch)
treeef846131df7515281b4ae6eeab9927251daa10a5 /README.md
parent68ddf8c6d2ed999fda27c9fdc9029ddd077b0c68 (diff)
downloadisort-d91f45286ca8f7a05e17ff0edc20f35d54a80c7d.tar.gz
Docs: mention isort[pyproject] extra in README
Diffstat (limited to 'README.md')
-rw-r--r--README.md9
1 files changed, 8 insertions, 1 deletions
diff --git a/README.md b/README.md
index af4d2a5c..f127f3a2 100644
--- a/README.md
+++ b/README.md
@@ -107,6 +107,12 @@ Install isort with both formats support:
pip install isort[requirements,pipfile]
```
+Install isort with support for reading configuration from `pyproject.toml`:
+
+```bash
+pip install isort[pyproject]
+```
+
Using isort
===========
@@ -272,7 +278,8 @@ Or, if you prefer, you can add an `isort` or `tool:isort` section to
your project's `setup.cfg` or `tox.ini` file with any desired settings.
You can also add your desired settings under a `[tool.isort]` section in
-your `pyproject.toml` file.
+your `pyproject.toml` file. For `pyproject.toml` support, use
+`pip install isort[pyproject]`.
You can then override any of these settings by using command line
arguments, or by passing in override values to the SortImports class.