summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2021-11-23 14:56:15 -0800
committerTimothy Crosley <timothy.crosley@gmail.com>2021-11-23 14:56:15 -0800
commit6a730a0860b31f185b3723a86db29d820ccfd065 (patch)
treedd8605cc1531626d31d47ea89059d65f8ad5c9b7 /scripts
parent4a8d2f6bd2e95f12982a772422c10dccde5ba869 (diff)
downloadisort-6a730a0860b31f185b3723a86db29d820ccfd065.tar.gz
Improve formatting of config option documentation
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/build_config_option_docs.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/scripts/build_config_option_docs.py b/scripts/build_config_option_docs.py
index 062e23b8..041937ef 100755
--- a/scripts/build_config_option_docs.py
+++ b/scripts/build_config_option_docs.py
@@ -291,6 +291,13 @@ blocked_extensions = ["pyw", "pyc"]
),
"multi_line_output": Example(cfg="multi_line_output=3", pyproject_toml="multi_line_output = 3"),
"show_version": Example(cli="isort --version"),
+ "py_version": Example(cli="isort --py 39",
+ pyproject_toml="""
+py_version=39
+""",
+ cfg="""
+py_version=39
+""")
}
@@ -335,6 +342,8 @@ def config_default(default: Any) -> str:
if default_str in CONFIG_DEFAULTS:
return CONFIG_DEFAULTS[default_str]
+ if default_str.startswith("py"):
+ return default_str[2:]
return default_str