summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Fayolle <alexandre.fayolle@logilab.fr>2008-01-08 12:31:09 +0100
committerAlexandre Fayolle <alexandre.fayolle@logilab.fr>2008-01-08 12:31:09 +0100
commit12a6235afa0bd6ab4e769cfdb770f2921de90b1e (patch)
treef730ba412a08a82eb76bade5b573062965cd77e2
parent4d9de7147c875039fb0fd84e57106f5695cfbc23 (diff)
downloadlogilab-common-12a6235afa0bd6ab4e769cfdb770f2921de90b1e.tar.gz
fixed lintian warning and errors
-rw-r--r--MANIFEST.in1
-rw-r--r--debian/changelog3
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules4
-rw-r--r--doc/pytest.162
5 files changed, 70 insertions, 6 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 45f977a..a0c9338 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -6,3 +6,4 @@ include bin/pytest
include bin/pytest.bat
recursive-include test/data *.py *.txt *.msg *.ini
recursive-include doc/html *
+include doc/pytest.1
diff --git a/debian/changelog b/debian/changelog
index 5d022a9..cd61b54 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
logilab-common (0.26.1-1) unstable; urgency=low
* new upstream release
+ * updated standards to 3.7.3
+ * Fixed Homepage header
+ * tests are no longer installed in the doc package
-- Alexandre Fayolle <afayolle@debian.org> Tue, 08 Jan 2008 09:38:22 +0100
diff --git a/debian/control b/debian/control
index 478cf2e..0a1786e 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,8 @@ Uploaders: David Douard <david.douard@logilab.fr>
Build-Depends: debhelper (>= 5.0.38)
Build-Depends-Indep: python (>=2.3.5-7), python-central (>=0.5.6)
XS-Python-Version: all
-Standards-Version: 3.7.2
+Homepage: http://www.logilab.org/Project/name/logilab-common
+Standards-Version: 3.7.3
Package: python-logilab-common
Architecture: all
@@ -26,6 +27,5 @@ Description: useful miscellaneous modules used by Logilab projects
* accessing RDBMS (currently postgreSQL, mysql and sqlite)
* generating text and HTML reports
* logging
- .
- Homepage: http://www.logilab.org/Project/name/logilab-common
+
diff --git a/debian/rules b/debian/rules
index eeb71e2..caa0320 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,7 +5,7 @@
# adapted by Logilab for automatic generation by debianize
# (part of the devtools project, http://www.logilab.org/projects/devtools)
#
-# Copyright (c) 2003-2005 LOGILAB S.A. (Paris, FRANCE).
+# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
# http://www.logilab.fr/ -- mailto:contact@logilab.fr
# Uncomment this to turn on verbose mode.
@@ -34,8 +34,6 @@ install: build
python setup.py -q install --no-compile --prefix=debian/python-logilab-common/usr/ --install-headers=debian/python-logilab-common/usr/include/ --install-scripts=debian/python-logilab-common/usr/bin
# remove test directory (installed in in the doc directory)
rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
- # install tests
- (cd test && find . -type f -not \( -path '*/CVS/*' -or -name '*.pyc' \) -exec install -D --mode=644 {} ../debian/python-logilab-common/usr/share/doc/python-logilab-common/test/{} \;)
# Build architecture-independent files here.
diff --git a/doc/pytest.1 b/doc/pytest.1
new file mode 100644
index 0000000..2425fa2
--- /dev/null
+++ b/doc/pytest.1
@@ -0,0 +1,62 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.36.
+.TH PYTEST "1" "January 2008" "run python unit tests" "User Commands"
+.SH NAME
+pytest
+.SH DESCRIPTION
+usage: pytest [OPTIONS] [testfile [testpattern]]
+.PP
+examples:
+.PP
+pytest path/to/mytests.py
+pytest path/to/mytests.py TheseTests
+pytest path/to/mytests.py TheseTests.test_thisone
+.PP
+pytest one (will run both test_thisone and test_thatone)
+pytest path/to/mytests.py \fB\-s\fR not (will skip test_notthisone)
+.PP
+pytest \fB\-\-coverage\fR test_foo.py
+.IP
+(only if logilab.devtools is available)
+.SS "options:"
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+show this help message and exit
+.TP
+\fB\-t\fR TESTDIR
+directory where the tests will be found
+.TP
+\fB\-d\fR
+enable design\-by\-contract
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+Verbose output
+.TP
+\fB\-i\fR, \fB\-\-pdb\fR
+Enable test failure inspection (conflicts with
+\fB\-\-coverage\fR)
+.TP
+\fB\-x\fR, \fB\-\-exitfirst\fR
+Exit on first failure (only make sense when pytest run
+one test file)
+.TP
+\fB\-c\fR, \fB\-\-capture\fR
+Captures and prints standard out/err only on errors
+(only make sense when pytest run one test file)
+.TP
+\fB\-p\fR PRINTONLY, \fB\-\-printonly\fR=\fIPRINTONLY\fR
+Only prints lines matching specified pattern (implies
+capture) (only make sense when pytest run one test
+file)
+.TP
+\fB\-s\fR SKIPPED, \fB\-\-skip\fR=\fISKIPPED\fR
+test names matching this name will be skipped to skip
+several patterns, use commas
+.TP
+\fB\-q\fR, \fB\-\-quiet\fR
+Minimal output
+.TP
+\fB\-P\fR PROFILE, \fB\-\-profile\fR=\fIPROFILE\fR
+Profile execution and store data in the given file
+.TP
+\fB\-\-coverage\fR
+run tests with pycoverage (conflicts with \fB\-\-pdb\fR)