summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Douard <david.douard@logilab.fr>2007-06-19 10:23:34 +0200
committerDavid Douard <david.douard@logilab.fr>2007-06-19 10:23:34 +0200
commit55aeeef6af468b0a9cec9b083c152fa17e445272 (patch)
tree8867ba9542b55171a61d0a5d5b15bdb2821aee1b
parent21b93c832a4481607ee19e515dbb8cd458e0691a (diff)
parentfb33919b81461e15601cc7e467ba7035d7984328 (diff)
downloadlogilab-common-55aeeef6af468b0a9cec9b083c152fa17e445272.tar.gz
merge
-rw-r--r--ChangeLog7
-rw-r--r--__pkginfo__.py2
-rw-r--r--debian/changelog6
-rw-r--r--debian/control3
-rw-r--r--pytest.py8
5 files changed, 19 insertions, 7 deletions
diff --git a/ChangeLog b/ChangeLog
index 4ed125c..c09cb90 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,13 @@
ChangeLog for logilab.common
============================
+2007-05-14 -- 0.22.1
+ * important bug fix in bd.py
+ * added history in pytest debugger sessions
+ * fix pytest coverage bug
+ * fix textutils test
+ * fix a bug which provoqued a crash if devtools was not installed
+
2007-05-14 -- 0.22.0
* pytest improvements
* shellutils: use shutil.move instead of os.rename as default action
diff --git a/__pkginfo__.py b/__pkginfo__.py
index 353af8d..062d325 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -17,7 +17,7 @@
distname = 'logilab-common'
modname = 'common'
-numversion = (0, 22, 0)
+numversion = (0, 22, 1)
version = '.'.join([str(num) for num in numversion])
license = 'GPL'
diff --git a/debian/changelog b/debian/changelog
index 883be7b..212c9b8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+logilab-common (0.22.1-1) unstable; urgency=low
+
+ * new upstream release
+
+ -- David Douard <david.douard@logilab.fr> Mon, 18 Jun 2007 11:44:19 +0200
+
logilab-common (0.22.0-1) unstable; urgency=low
* new upstream release
diff --git a/debian/control b/debian/control
index 56044cc..478cf2e 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,8 @@
Source: logilab-common
Section: python
Priority: optional
-Maintainer: Alexandre Fayolle <afayolle@debian.org>
+Maintainer: Alexandre Fayolle <afayolle@debian.org>
+Uploaders: David Douard <david.douard@logilab.fr>
Build-Depends: debhelper (>= 5.0.38)
Build-Depends-Indep: python (>=2.3.5-7), python-central (>=0.5.6)
XS-Python-Version: all
diff --git a/pytest.py b/pytest.py
index aff35fe..a1a03cc 100644
--- a/pytest.py
+++ b/pytest.py
@@ -10,7 +10,7 @@ pytest one (will run both test_thisone and test_thatone)
pytest path/to/mytests.py -s not (will skip test_notthisone)
pytest --coverage test_foo.py
- (only of logilab.devtools is available)
+ (only if logilab.devtools is available)
"""
import os, sys
@@ -321,13 +321,11 @@ def parseargs():
try:
from logilab.devtools.lib.coverage import Coverage
- except ImportError:
- print "kouch kouch"
- pass
- else:
parser.add_option('--coverage', dest="coverage", default=False,
action="store_true",
help="run tests with pycoverage (conflicts with --pdb)")
+ except ImportError:
+ pass
# parse the command line
options, args = parser.parse_args()