summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Peuch <cortex@worlddomination.be>2020-05-29 10:40:08 +0200
committerLaurent Peuch <cortex@worlddomination.be>2020-05-29 10:40:08 +0200
commit8f776029a73015e74424fd01925f2f12bbb99724 (patch)
tree5ab7d8248f82a7278c9038144179fc69408d3f02
parente2cbc7ca459c6a79fa83653b9df06768e765548a (diff)
downloadlogilab-common-8f776029a73015e74424fd01925f2f12bbb99724.tar.gz
[doc] update Changelog
-rw-r--r--ChangeLog43
1 files changed, 43 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index bcba0ae..7aef086 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,49 @@
ChangeLog for logilab.common
============================
+unreleased -- 1.7.0
+
+ * logilab-common requires python 3.6 now
+ * greatly improve our CI and migrate it to heptapod/gitlab-ci
+ * black the whole code base
+ * move test suit to pytest
+ * use check-manifest and fix related bugs in MANIFEST.in
+ * integrates flake8 and please the flake8 gods
+ * various fixes
+ * class_deprecation is not a class anymore
+ * pytest 5.4.2 breaks tests, pin to 5.4.1 for now
+
+2020-05-25 -- 1.6.4
+
+ * fix: rollback to old class_deprecation being a class behavior
+ * fix: @functools.wraps broke callable_renamed, write a @lazy_wraps and
+ use it everywhere in logilab.common.deprecation
+ * add docstring to LazyObject
+
+2020-05-11 -- 1.6.3
+
+ * fix: metaclass conflict in class_deprecated
+
+2020-05-11 -- 1.6.2
+
+ * fix: explicitly requires python 3.6 in setup.py
+
+2020-05-01 -- 1.6.1
+
+ * bug fix, bad usage of callable_renamed
+
+2020-04-30 -- 1.6.0
+
+ * logilab-common requires python >= 3.6 now
+ * use pyannotates to introduces types in all the modules
+ * introduce a list of new functions in logilab.common.deprecation: callable_renamed, attribute_renamed, argument_renamed, argument_remove
+ * renamed "renamed" to "callable_renamed", "deprecated" to
+ "callable_deprecated", "moved" to "callable_moved" for coherence
+ * refactor the whole logilab.common.deprecation to simplify its code
+ * automatically detect from which modules a deprecated utils is called
+ * correctly display the line where a deprecated utils is used
+ * various small fixes, thx mypy
+
2019-12-04 -- 1.5.2
* documentation is now available at https://logilab-common.readthedocs.io/