summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Peuch <cortex@worlddomination.be>2020-07-07 18:49:26 +0200
committerLaurent Peuch <cortex@worlddomination.be>2020-07-07 18:49:26 +0200
commita5208bbd68a108c9bbed6f20ab1e801a004b982f (patch)
tree0df01c301d98884d1acdc52b7e48f08bc8a47a59
parentfcc526e63d7c1333845dd7ebba97db646aba7bcd (diff)
downloadlogilab-common-a5208bbd68a108c9bbed6f20ab1e801a004b982f.tar.gz
type: declare that logilab-common ship type annotations
-rw-r--r--MANIFEST.in1
-rw-r--r--logilab/common/py.typed0
-rw-r--r--setup.py2
3 files changed, 3 insertions, 0 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 3af9297..530b572 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -7,6 +7,7 @@ include bin/logilab-pytest.bat
include test/data/ChangeLog
include tox.ini
include *.txt
+include logilab/common/py.typed
recursive-include test *.py *.txt *.msg *.ini *.zip *.egg
recursive-include test/data/*_dir *
recursive-include test/input *.py
diff --git a/logilab/common/py.typed b/logilab/common/py.typed
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/logilab/common/py.typed
diff --git a/setup.py b/setup.py
index a577530..2108e40 100644
--- a/setup.py
+++ b/setup.py
@@ -47,6 +47,8 @@ setup(
# See https://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=pkginfo["classifiers"],
packages=find_packages(exclude=["contrib", "docs", "test*"]),
+ package_data={"logilab.common": ["py.typed"]},
+ include_package_data=True,
namespace_packages=[pkginfo["subpackage_of"]],
python_requires=">=3.6",
install_requires=pkginfo["install_requires"],