summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Cristau <julien.cristau@logilab.fr>2014-09-22 16:05:59 +0200
committerJulien Cristau <julien.cristau@logilab.fr>2014-09-22 16:05:59 +0200
commitc7569393fbdd47253c22bf606e82cf1e3ea30fd6 (patch)
treeccdaf25af2bfc46867f6337c0d8e80f54f1ac5c0
parent30937b08ed70f51fa5785b419bda47f122157c3c (diff)
downloadlogilab-common-c7569393fbdd47253c22bf606e82cf1e3ea30fd6.tar.gz
[pkg] add dependency on six
Will help us make the source python 2.x and 3.x compatible. Require version 1.4.0 for six.moves.range and six.add_metaclass.
-rw-r--r--__pkginfo__.py4
-rw-r--r--debian/control10
-rw-r--r--python-logilab-common.spec1
3 files changed, 11 insertions, 4 deletions
diff --git a/__pkginfo__.py b/__pkginfo__.py
index a686df1..d2a8669 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -40,7 +40,9 @@ from os.path import join
scripts = [join('bin', 'pytest')]
include_dirs = [join('test', 'data')]
-install_requires = []
+install_requires = [
+ 'six >= 1.4.0',
+ ]
if sys.version_info < (2, 7):
install_requires.append('unittest2 >= 0.5.1')
if os.name == 'nt':
diff --git a/debian/control b/debian/control
index e0af5ee..9583845 100644
--- a/debian/control
+++ b/debian/control
@@ -11,12 +11,13 @@ Uploaders: David Douard <david.douard@logilab.fr>,
Julien Jehannet <julien.jehannet@debian.org>,
Build-Depends:
debhelper (>= 7),
- python (>= 2.5),
+ python (>= 2.6),
python-unittest2 | python (>= 2.7),
python-epydoc,
+ python-six (>= 1.4.0),
graphviz,
python-egenix-mxdatetime,
-XS-Python-Version: >= 2.5
+XS-Python-Version: >= 2.6
Standards-Version: 3.9.1
Homepage: http://www.logilab.org/project/logilab-common
Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
@@ -25,7 +26,10 @@ Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-commo
Package: python-logilab-common
Architecture: all
Provides: ${python:Provides}
-Depends: ${python:Depends}, ${misc:Depends}
+Depends:
+ python-six (>= 1.4.0),
+ ${python:Depends},
+ ${misc:Depends},
Suggests: pyro, python-unittest2, python-kerberos
Recommends: python-egenix-mxdatetime
Conflicts:
diff --git a/python-logilab-common.spec b/python-logilab-common.spec
index ba0e3ae..1136812 100644
--- a/python-logilab-common.spec
+++ b/python-logilab-common.spec
@@ -23,6 +23,7 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: python-devel python-setuptools python-unittest2
Requires: mx
+Requires: %{python}-six >= 1.4.0
%description