summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurent Peuch <cortex@worlddomination.be>2019-06-19 19:43:24 +0200
committerLaurent Peuch <cortex@worlddomination.be>2019-06-19 19:43:24 +0200
commite9073cbe4d43ae80be4d2cf4bacf91c4bdc652cd (patch)
tree91bd6b693c6d78f0c14e98ddf5db5d06478630d8
parent8f7b9d9654d9cf73e067d33053b875534d25868e (diff)
downloadlogilab-common-e9073cbe4d43ae80be4d2cf4bacf91c4bdc652cd.tar.gz
[doc] include README into doc index.rst to avoid duplication
-rw-r--r--README66
-rw-r--r--doc/index.rst162
2 files changed, 41 insertions, 187 deletions
diff --git a/README b/README
index 21cbe78..724faad 100644
--- a/README
+++ b/README
@@ -26,11 +26,11 @@ Installation
Extract the tarball, jump into the created directory and run ::
- python setup.py install
+ python setup.py install
For installation options, see ::
- python setup.py install --help
+ python setup.py install --help
Provided modules
@@ -41,80 +41,80 @@ Here is a brief description of the available modules.
Modules providing high-level features
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-* `cache`, a cache implementation with a least recently used algorithm.
+* :ref:`cache <cache>`, a cache implementation with a least recently used algorithm.
-* `changelog`, a tiny library to manipulate our simplified ChangeLog file format.
+* :ref:`changelog <changelog>`, a tiny library to manipulate our simplified ChangeLog file format.
-* `clcommands`, high-level classes to define command line programs handling
+* :ref:`clcommands <clcommands>`, high-level classes to define command line programs handling
different subcommands. It is based on `configuration` to get easy command line
/ configuration file handling.
-* `configuration`, some classes to handle unified configuration from both
+* :ref:`configuration <configuration>`, some classes to handle unified configuration from both
command line (using optparse) and configuration file (using ConfigParser).
-* `proc`, interface to Linux /proc.
+* :ref:`proc <proc>`, interface to Linux /proc.
-* `umessage`, unicode email support.
+* :ref:`umessage <umessage>`, unicode email support.
-* `ureports`, micro-reports, a way to create simple reports using python objects
+* :ref:`ureports <ureports>`, micro-reports, a way to create simple reports using python objects
without care of the final formatting. ReST and html formatters are provided.
Modules providing low-level functions and structures
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-* `compat`, provides a transparent compatibility layer between different python
+* :ref:`compat <compat>`, provides a transparent compatibility layer between different python
versions.
-* `date`, a set of date manipulation functions.
+* :ref:`date <date>`, a set of date manipulation functions.
-* `daemon`, a daemon function and mix-in class to properly start an Unix daemon
+* :ref:`daemon <daemon>`, a daemon function and mix-in class to properly start an Unix daemon
process.
-* `decorators`, function decorators such as cached, timed...
+* :ref:`decorators <decorators>`, function decorators such as cached, timed...
-* `deprecation`, decorator, metaclass & all to mark functions / classes as
+* :ref:`deprecation <deprecation>`, decorator, metaclass & all to mark functions / classes as
deprecated or moved
-* `fileutils`, some file / file path manipulation utilities.
+* :ref:`fileutils <fileutils>`, some file / file path manipulation utilities.
-* `graph`, graph manipulations functions such as cycle detection, bases for dot
+* :ref:`graph <graph>`, graph manipulations functions such as cycle detection, bases for dot
file generation.
-* `modutils`, python module manipulation functions.
+* :ref:`modutils <modutils>`, python module manipulation functions.
-* `shellutils`, some powerful shell like functions to replace shell scripts with
+* :ref:`shellutils <shellutils>`, some powerful shell like functions to replace shell scripts with
python scripts.
-* `tasksqueue`, a prioritized tasks queue implementation.
+* :ref:`tasksqueue <tasksqueue>`, a prioritized tasks queue implementation.
-* `textutils`, some text manipulation functions (ansi colorization, line wrapping,
+* :ref:`textutils <textutils>`, some text manipulation functions (ansi colorization, line wrapping,
rest support...).
-* `tree`, base class to represent tree structure, and some others to make it
+* :ref:`tree <tree>`, base class to represent tree structure, and some others to make it
works with the visitor implementation (see below).
-* `visitor`, a generic visitor pattern implementation.
+* :ref:`visitor <visitor>`, a generic visitor pattern implementation.
Modules extending some standard modules
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-* `debugger`, `pdb` customization.
+* :ref:`debugger <debugger>`, `pdb` customization.
-* `logging_ext`, extensions to `logging` module such as a colorized formatter
+* :ref:`logging_ext <logging_ext>`, extensions to `logging` module such as a colorized formatter
and an easier initialization function.
-* `optik_ext`, defines some new option types (regexp, csv, color, date, etc.)
+* :ref:`optik_ext <optik_ext>`, defines some new option types (regexp, csv, color, date, etc.)
for `optik` / `optparse`
Modules extending some external modules
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-* `sphinx_ext`, Sphinx_ plugin defining a `autodocstring` directive.
+* :ref:`sphinx_ext <sphinx_ext>`, Sphinx_ plugin defining a `autodocstring` directive.
-* `vcgutils` , utilities functions to generate file readable with Georg Sander's
+* :ref:`vcgutils <vcgutils>` , utilities functions to generate file readable with Georg Sander's
vcg tool (Visualization of Compiler Graphs).
@@ -135,16 +135,10 @@ Comments, support, bug reports
Project page https://www.logilab.org/project/logilab-common
-Use the python-projects@lists.logilab.org mailing list.
+Use the cubicweb-devel at lists.cubicweb.org mailing list.
You can subscribe to this mailing list at
-https://lists.logilab.org/mailman/listinfo/python-projects
+https://lists.cubicweb.org/mailman/listinfo/cubicweb-devel
Archives are available at
-https://lists.logilab.org/pipermail/python-projects/
-
-
-.. _Sphinx: http://sphinx.pocoo.org/
-.. _`unittest2`: http://pypi.python.org/pypi/unittest2
-.. _`discover`: http://pypi.python.org/pypi/discover
-.. _`zope.interface`: http://pypi.python.org/pypi/zope.interface
+https://lists.cubicweb.org/pipermail/cubicweb-devel/
diff --git a/doc/index.rst b/doc/index.rst
index fe11f0f..47d17ab 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -3,167 +3,27 @@
You can adapt this file completely to your liking, but it should at least
contain the root `toctree` directive.
-Welcome to logilab common's documentation!
-==========================================
-
-Logilab common's is a bunch of modules providing low level functionnalities
-shared among some python projects devel by Logilab.
-
-What's this ?
--------------
-
-This package contains some modules used by different Logilab projects.
-
-It is released under the GNU Lesser General Public License.
-
-There is no documentation available yet but the source code should be clean and
-well documented.
-
-Designed to ease:
-
-* handling command line options and configuration files
-* writing interactive command line tools
-* manipulation of files and character strings
-* manipulation of common structures such as graph, tree, and pattern such as visitor
-* generating text and HTML reports
-* more...
-
-
-Installation
-------------
-
-Extract the tarball, jump into the created directory and run ::
-
- python setup.py install
-
-For installation options, see ::
-
- python setup.py install --help
-
-
-Provided modules
-----------------
-
-Here is a brief description of the available modules.
-
-Modules providing high-level features
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-* :ref:`cache <cache>`, a cache implementation with a least recently used algorithm.
-
-* :ref:`changelog <changelog>`, a tiny library to manipulate our simplified ChangeLog file format.
-
-* :ref:`clcommands <clcommands>`, high-level classes to define command line programs handling
- different subcommands. It is based on `configuration` to get easy command line
- / configuration file handling.
-
-* :ref:`configuration <configuration>`, some classes to handle unified configuration from both
- command line (using optparse) and configuration file (using ConfigParser).
-
-* :ref:`proc <proc>`, interface to Linux /proc.
-
-* :ref:`umessage <umessage>`, unicode email support.
-
-* :ref:`ureports <ureports>`, micro-reports, a way to create simple reports using python objects
- without care of the final formatting. ReST and html formatters are provided.
-
-
-Modules providing low-level functions and structures
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-* :ref:`compat <compat>`, provides a transparent compatibility layer between different python
- versions.
-
-* :ref:`date <date>`, a set of date manipulation functions.
-
-* :ref:`daemon <daemon>`, a daemon function and mix-in class to properly start an Unix daemon
- process.
-
-* :ref:`decorators <decorators>`, function decorators such as cached, timed...
-
-* :ref:`deprecation <deprecation>`, decorator, metaclass & all to mark functions / classes as
- deprecated or moved
-
-* :ref:`fileutils <fileutils>`, some file / file path manipulation utilities.
-
-* :ref:`graph <graph>`, graph manipulations functions such as cycle detection, bases for dot
- file generation.
-
-* :ref:`modutils <modutils>`, python module manipulation functions.
-
-* :ref:`shellutils <shellutils>`, some powerful shell like functions to replace shell scripts with
- python scripts.
-
-* :ref:`tasksqueue <tasksqueue>`, a prioritized tasks queue implementation.
-
-* :ref:`textutils <textutils>`, some text manipulation functions (ansi colorization, line wrapping,
- rest support...).
-
-* :ref:`tree <tree>`, base class to represent tree structure, and some others to make it
- works with the visitor implementation (see below).
-
-* :ref:`visitor <visitor>`, a generic visitor pattern implementation.
-
-
-Modules extending some standard modules
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-* :ref:`debugger <debugger>`, `pdb` customization.
-
-* :ref:`logging_ext <logging_ext>`, extensions to `logging` module such as a colorized formatter
- and an easier initialization function.
-
-* :ref:`optik_ext <optik_ext>`, defines some new option types (regexp, csv, color, date, etc.)
- for `optik` / `optparse`
-
-
-Modules extending some external modules
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-* :ref:`sphinx_ext <sphinx_ext>`, Sphinx_ plugin defining a `autodocstring` directive.
-
-* :ref:`vcgutils <vcgutils>` , utilities functions to generate file readable with Georg Sander's
- vcg tool (Visualization of Compiler Graphs).
-
-
-To be deprecated modules
-~~~~~~~~~~~~~~~~~~~~~~~~
-
-Those `logilab.common` modules will much probably be deprecated in future
-versions:
-
-* `testlib`: use `unittest2`_ instead
-* `interface`: use `zope.interface`_ if you really want this
-* `table`, `xmlutils`: is that used?
-* `sphinxutils`: we won't go that way imo (i == syt)
-
-
-Comments, support, bug reports
-------------------------------
-
-Project page https://www.logilab.org/project/logilab-common
-
-Use the cubicweb-devel at lists.cubicweb.org mailing list.
-
-You can subscribe to this mailing list at
-https://lists.cubicweb.org/mailman/listinfo/cubicweb-devel
-
-Archives are available at
-https://lists.cubicweb.org/pipermail/cubicweb-devel/
-
+.. include:: ../README
.. _Sphinx: http://sphinx.pocoo.org/
.. _`unittest2`: http://pypi.python.org/pypi/unittest2
.. _`discover`: http://pypi.python.org/pypi/discover
.. _`zope.interface`: http://pypi.python.org/pypi/zope.interface
+Reference
+=========
+
.. toctree::
:maxdepth: 2
:caption: Contents:
+ logilab.common
+ logilab.common.ureports
+
+
Indices and tables
==================
-* `genindex`
-* `modindex`
-* `search`
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`