summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDenis Laxalde <denis.laxalde@logilab.fr>2016-11-18 13:26:25 +0100
committerDenis Laxalde <denis.laxalde@logilab.fr>2016-11-18 13:26:25 +0100
commit1c87803f38d1887a087685b9f431818b8f98a598 (patch)
tree74612799acb104d35730887cca4ec13b6e5f0773 /debian
parentd4f18655e76a87ec49b31787e09f42fb8d6cf5b5 (diff)
downloadlogilab-common-1c87803f38d1887a087685b9f431818b8f98a598.tar.gz
[debian] Use logilab-pytest executable directlydebian/1.3.0-1centos/1.3.0-11.3.0
To please damned Apycot, hopefully.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index f918efe..5dfe654 100755
--- a/debian/rules
+++ b/debian/rules
@@ -69,12 +69,12 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
python setup.py install \
--root=$(CURDIR)/testing/ ${py_setup_install_args}
echo 'import site, os.path; site.addsitedir(os.path.dirname(__file__))' > testing/$(PYLIB)/sitecustomize.py
- PYTHONPATH=$(CURDIR)/testing/$(PYLIB) python -m logilab.common.pytest -t $(CURDIR)/test
+ PYTHONPATH=$(CURDIR)/testing/$(PYLIB) $(CURDIR)/testing/usr/bin/logilab-pytest -t $(CURDIR)/test
ifneq (,$(build_py3k))
python3 setup.py install \
--root=$(CURDIR)/testing/ ${py_setup_install_args}
echo 'import site, os.path; site.addsitedir(os.path.dirname(__file__))' > testing/$(PYLIB3)/sitecustomize.py
- PYTHONPATH=$(CURDIR)/testing/$(PYLIB3) python3 logilab.common.pytest -t $(CURDIR)/test
+ PYTHONPATH=$(CURDIR)/testing/$(PYLIB3) $(CURDIR)/testing/usr/bin/logilab-pytest -t $(CURDIR)/test
endif
endif