summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJulien Cristau <julien.cristau@logilab.fr>2014-11-05 14:23:07 +0100
committerJulien Cristau <julien.cristau@logilab.fr>2014-11-05 14:23:07 +0100
commitb3bc802c72128b3cb0891638c9955ff9c517e913 (patch)
treecf87ed38eb0bc456a7c58bcf638f3ce184d49976 /debian
parent5152e40e88daa9808ef1f701ed39752e944ce8da (diff)
downloadlogilab-common-b3bc802c72128b3cb0891638c9955ff9c517e913.tar.gz
[debian] fix package and docs build
Add six build-dep so we can run tests, and build the lib where doc/makefile expects it before building API docs.
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules12
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 2ecbc8a..8c47001 100644
--- a/debian/control
+++ b/debian/control
@@ -16,6 +16,8 @@ Build-Depends-Indep:
graphviz,
python-unittest2,
python-egenix-mxdatetime,
+ python-six (>= 1.4.0),
+ python3-six (>= 1.4.0) | python3 (<< 3.3),
X-Python3-Version: >= 3.3
X-Python-Version: >= 2.6
Standards-Version: 3.9.1
diff --git a/debian/rules b/debian/rules
index eaa95bc..c54fe35 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,7 +30,9 @@ build: build-indep
dh $@ --with python2,python3
override_dh_auto_build:
+ dh_auto_build
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
+ NO_SETUPTOOLS=1 python setup.py -q build --build-purelib build/lib
$(MAKE) -C doc
endif
@@ -57,10 +59,9 @@ ifneq (,$(build_py3k))
endif
override_dh_installdocs:
- dh_installchangelogs -i ChangeLog
- dh_installdocs -i README*
+ dh_installdocs README*
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
- dh_installdocs -i doc/apidoc/
+ dh_installdocs doc/apidoc/
endif
override_dh_auto_test:
@@ -90,3 +91,8 @@ endif
override_dh_compress:
dh_compress -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
+
+override_dh_clean:
+ dh_clean
+ rm -rf doc/apidoc
+ rm -rf logilab_common.egg-info