summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index f918efe..5dfe654 100755
--- a/debian/rules
+++ b/debian/rules
@@ -69,12 +69,12 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
python setup.py install \
--root=$(CURDIR)/testing/ ${py_setup_install_args}
echo 'import site, os.path; site.addsitedir(os.path.dirname(__file__))' > testing/$(PYLIB)/sitecustomize.py
- PYTHONPATH=$(CURDIR)/testing/$(PYLIB) python -m logilab.common.pytest -t $(CURDIR)/test
+ PYTHONPATH=$(CURDIR)/testing/$(PYLIB) $(CURDIR)/testing/usr/bin/logilab-pytest -t $(CURDIR)/test
ifneq (,$(build_py3k))
python3 setup.py install \
--root=$(CURDIR)/testing/ ${py_setup_install_args}
echo 'import site, os.path; site.addsitedir(os.path.dirname(__file__))' > testing/$(PYLIB3)/sitecustomize.py
- PYTHONPATH=$(CURDIR)/testing/$(PYLIB3) python3 logilab.common.pytest -t $(CURDIR)/test
+ PYTHONPATH=$(CURDIR)/testing/$(PYLIB3) $(CURDIR)/testing/usr/bin/logilab-pytest -t $(CURDIR)/test
endif
endif