summaryrefslogtreecommitdiff
path: root/debian.jaunty/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian.jaunty/rules')
-rwxr-xr-xdebian.jaunty/rules81
1 files changed, 81 insertions, 0 deletions
diff --git a/debian.jaunty/rules b/debian.jaunty/rules
new file mode 100755
index 0000000..f1f9362
--- /dev/null
+++ b/debian.jaunty/rules
@@ -0,0 +1,81 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+#
+# adapted by Logilab for automatic generation by debianize
+# (part of the devtools project, http://www.logilab.org/projects/devtools)
+#
+# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
+# http://www.logilab.fr/ -- mailto:contact@logilab.fr
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ # python module build
+ NO_SETUPTOOLS=1 python setup.py -q build --build-purelib build/lib
+
+ # run tests
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ # we need this hack because we have to import "logilab.common.pytest"
+ # but since it's a namespace package, we need to "simulate" it
+ touch $(CURDIR)/build/lib/logilab/__init__.py
+ -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.6/pytest
+ rm -f $(CURDIR)/build/lib/logilab/__init__.py
+endif
+
+ # build doc
+ $(MAKE) -C doc
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ # clean doc
+ $(MAKE) -C doc clean
+
+ NO_SETUPTOOLS=1 python setup.py clean
+
+ [ ! -d build ] || rm -rf build
+
+ find . -name "*.pyc" -delete
+
+ dh_clean build-stamp
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ NO_SETUPTOOLS=1 python setup.py -q install --no-compile --root=debian/python-logilab-common/ --install-headers=usr/include/ --install-scripts=usr/bin/
+ # remove test directory
+ rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_install -i
+ dh_pysupport -i
+ dh_installchangelogs -i ChangeLog
+ dh_installexamples -i
+ dh_installdocs -i README doc/apidoc/
+ dh_installman -i
+ dh_link -i
+ dh_compress -i -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary-arch:
+
+binary: binary-indep
+.PHONY: build clean binary binary-indep binary-arch