summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinay Sajip <vinay_sajip@yahoo.co.uk>2017-02-20 18:22:38 +0000
committerVinay Sajip <vinay_sajip@yahoo.co.uk>2017-02-20 18:22:38 +0000
commit24e74cfb2924c63f0c6b8b39471a7d7fd65bbfdc (patch)
tree79c6accaf48d5b37de06b785a4cc03bbeea913c4
parent9b861dfb494c4077688b9968868fc80836cdda28 (diff)
downloadlogutils-git-24e74cfb2924c63f0c6b8b39471a7d7fd65bbfdc.tar.gz
Updated README format.0.3.4
-rw-r--r--README.rst (renamed from README.txt)13
-rw-r--r--setup.py4
2 files changed, 12 insertions, 5 deletions
diff --git a/README.txt b/README.rst
index a60fbaf..0070fea 100644
--- a/README.txt
+++ b/README.rst
@@ -1,3 +1,9 @@
+.. image:: https://travis-ci.org/vsajip/logutils.svg
+ :target: https://travis-ci.org/vsajip/logutils
+
+.. image:: https://coveralls.io/repos/vsajip/logutils/badge.svg
+ :target: https://coveralls.io/github/vsajip/logutils
+
logutils 0.3.4
==============
The logutils package provides a set of handlers for the Python standard
@@ -23,12 +29,13 @@ before running the installation.
Availability & Documentation
----------------------------
-The latest version of logutils can be found at:
-
- http://code.google.com/p/logutils/
The source code repository is at:
https://bitbucket.org/vinay.sajip/logutils/
+Documentation is available at:
+
+https://logutils.readthedocs.io/
+https://pythonhosted.org/logutils/
diff --git a/setup.py b/setup.py
index 7ee0117..f0891d6 100644
--- a/setup.py
+++ b/setup.py
@@ -7,10 +7,10 @@ import re
def description():
- f = open(join(dirname(__file__), 'README.txt'))
+ f = open(join(dirname(__file__), 'README.rst'))
readme = f.read()
f.close()
- regexp = r'^logutils\s*[\d.]*\s*\n=======+\s*\n(.*)Requirements '
+ regexp = r'logutils\s*[\d.]*\s*\n=======+\s*\n(.*)Requirements '
reqts, = re.findall(regexp, readme, re.DOTALL)
regexp = r'Availability & Documentation\s*\n-----+\s*\n(.*)'
avail, = re.findall(regexp, readme, re.DOTALL)