summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinay Sajip <vinay_sajip@yahoo.co.uk>2019-06-19 11:00:22 +0100
committerVinay Sajip <vinay_sajip@yahoo.co.uk>2019-06-19 11:00:22 +0100
commit2aaba19b1fa7cafbe589c04bcbf6b2cab2b0aefa (patch)
tree04980a0c6af4c1c96e6946098eae85f015a80952
parentf8a4eafb60be0bd0d062f00a94e88a1505b85c51 (diff)
downloadlogutils-git-2aaba19b1fa7cafbe589c04bcbf6b2cab2b0aefa.tar.gz
Updated AppVeyor configuration and removed unused test code.
-rw-r--r--appveyor.yml4
-rw-r--r--setup.py32
2 files changed, 3 insertions, 33 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 5788896..1f574ff 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,6 +1,8 @@
version: 1.0.{build}
+image:
+ - Visual Studio 2017
+ - ubuntu1804
environment:
- TESTING_ON_AV: 1
matrix:
- TOXENV: py27
- TOXENV: py35
diff --git a/setup.py b/setup.py
index 209345d..6a5c7ec 100644
--- a/setup.py
+++ b/setup.py
@@ -6,31 +6,6 @@ import os
from os.path import join, dirname, abspath
import re
-def missing_files():
- result = []
- if os.name == 'nt':
-
- def found_file(fn):
- if os.path.exists(fn):
- return True
- for d in os.environ['PATH'].split(os.pathsep):
- p = os.path.join(d, fn)
- if os.path.exists(p):
- return True
- return False
-
- FILES = ('cat.exe', 'echo.exe', 'tee.exe', 'false.exe', 'true.exe',
- 'sleep.exe', 'touch.exe')
- if 'TESTING_ON_AV' in os.environ:
- FILES = ('libiconv2.dll', 'libintl3.dll') + FILES
-
- missing = []
- for fn in FILES:
- if not found_file(fn):
- result.append(fn)
- return result
-
-
def description():
f = open(join(dirname(__file__), 'README.rst'))
readme = f.read()
@@ -45,13 +20,6 @@ class TestCommand(distutils.core.Command):
user_options = []
def run(self):
- missing = missing_files()
-
- if missing:
- missing = ', '.join(missing)
- raise ValueError('Can\'t find one or more files needed for '
- 'tests: %s' % missing)
-
import sys
import unittest