summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml17
1 files changed, 17 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..d88b797
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,17 @@
+language: python
+sudo: false
+python:
+ - "2.6"
+ - "2.7"
+# - "3.2" removed because Coveralls/coverage 4.0 fails on 3.2
+ - "3.3"
+ - "3.4"
+ - "3.5"
+ - "3.6"
+ - "pypy"
+install:
+ - pip install coveralls
+script:
+ - "python setup.py test"
+ - "coverage run setup.py test"
+after_success: coveralls