summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2023-03-28 23:32:14 +0200
committerMatěj Cepl <mcepl@cepl.eu>2023-03-28 23:32:14 +0200
commit370d29bf5419bba1a7263a89b369079506494cfc (patch)
tree159a8ff84cad2195f1cf69718f0e12170f0bcedd
parente4dd7c452b4eb01c65701178f1ce04ecfd60e07a (diff)
downloadm2crypto-master.tar.gz
Stop using GitHubHEADmaster
-rw-r--r--.github/workflows/main.yml37
1 files changed, 0 insertions, 37 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
deleted file mode 100644
index 75468cb..0000000
--- a/.github/workflows/main.yml
+++ /dev/null
@@ -1,37 +0,0 @@
-# This workflow will install Python dependencies, run tests and lint with a variety of Python versions
-# For more information see: https://help.github.com/actions/language-and-framework-guides/using-python-with-github-actions
-
-name: Python package
-
-on: [push, pull_request]
-
-jobs:
- test:
-
- runs-on: ubuntu-latest
- strategy:
- matrix:
- python-version: [2.7, 3.7, 3.8, 3.9, 3.11]
-
- steps:
- - uses: actions/checkout@v2
- - name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v2
- with:
- python-version: ${{ matrix.python-version }}
- - name: Install dependencies
- run: |
- python -m pip install --upgrade pip
- if [ -f dev-requirements.txt ]; then python -m pip install -r dev-requirements.txt; fi
- - name: Lint with flake8
- run: |
- # stop the build if there are Python syntax errors or undefined names
- python -mflake8 . --count --exclude six.py --select=E9,F63,F7,F82 --show-source --statistics
- # exit-zero treats all errors as warnings. The GitHub editor is 127 chars wide
- python -mflake8 . --count --exit-zero --exclude six.py --max-complexity=10 --max-line-length=127 --statistics
- - name: Running the test suite
- run: |
- set -x
- python setup.py clean build
- export PYTHONPATH=$(readlink -f build/lib.*)
- python -munittest discover -v