summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-11-27 09:46:01 +0100
committerMatěj Cepl <mcepl@cepl.eu>2017-12-18 17:45:10 +0100
commit03f0a262eec6eff52b373c21cbf95ba024f7e530 (patch)
tree89c35d519f107942367b339d482c8a82bbde902e /.gitlab-ci.yml
parentf81e20853289709f232f3564937cf0526fac08c4 (diff)
downloadm2crypto-03f0a262eec6eff52b373c21cbf95ba024f7e530.tar.gz
Fix GitLab CI to allow parallel jobs.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml34
1 files changed, 0 insertions, 34 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 74cbc59..d87f28e 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -1,20 +1,4 @@
-stages:
- - centos6
- # - python26
- - python27
- - python34
- - python36
- - fedora
-
-.python26:
- stage: python26
- image: yarara/python-2.6.9:v1
- when: always
- script:
- - python setup.py clean build test
-
fedora:
- stage: fedora
image: fedora:26
when: always
script:
@@ -24,7 +8,6 @@ fedora:
- python setup.py build test
centos6:
- stage: centos6
image: centos:6
when: always
script:
@@ -35,7 +18,6 @@ centos6:
- python setup.py build test
python27:
- stage: python27
image: python:2.7
when: always
script:
@@ -44,7 +26,6 @@ python27:
- python setup.py clean build test
python34:
- stage: python34
image: python:3.4
when: always
allow_failure: yes
@@ -55,7 +36,6 @@ python34:
- python3 setup.py clean build test
python36:
- stage: python36
image: python:3.6
when: always
allow_failure: yes
@@ -64,17 +44,3 @@ python36:
- apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools
- easy_install3 Twisted
- python3 setup.py clean build test
-
-.pypy:
- stage: pypy
- image: pypy:2
- when: always
- allow_failure: yes
- script:
- - if [ \! -f /etc/apt/sources.list.d/jessie-backports.list ] ;
- echo 'deb http://ftp.debian.org/debian jessie-backports main' > /etc/apt/sources.list.d/jessie-backports.list
- ; fi
- - apt-get update -q -y
- - apt-get install -y swig libssl-dev libssl1.0.0 pypy-dev openssl pypy-setuptools
- - easy_install Twisted
- - pypy setup.py clean build test