summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2015-10-14 08:39:02 +0200
committerMatěj Cepl <mcepl@cepl.eu>2015-10-16 01:51:51 +0200
commit07ee064e9ed446bc0678fb133e64eadaa9ed0be8 (patch)
tree9e5c535496539950ef03354f5f45986b63fc1034 /.gitlab-ci.yml
parentf48671f1687d7d06c77f0c4e3c7722a878cf732d (diff)
downloadm2crypto-07ee064e9ed446bc0678fb133e64eadaa9ed0be8.tar.gz
Add .travis.yml and .gitlab-ci.yml
Fixes #50
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml29
1 files changed, 29 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 0000000..8d25f73
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,29 @@
+image: python:2.7
+
+test:
+ script:
+ - apt-get -y swig libssl-dev libssl1.0.0
+ - python setup.py test
+
+# language: python
+#
+# addons:
+# apt:
+# packages:
+# - swig
+# - libssl-dev
+# - libssl1.0.0
+#
+# sudo: false
+#
+# python:
+# - 2.6
+# - 2.7
+#
+# before_script:
+# - '[ "${TRAVIS_PYTHON_VERSION}" = "2.6" ] && pip install --use-mirrors unittest2 || /bin/true'
+#
+# install:
+# - python setup.py install
+#
+# script: python setup.py test