summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2018-10-03 12:59:21 +0200
committerMatěj Cepl <mcepl@cepl.eu>2018-10-03 13:14:31 +0200
commit09f8808698a4f1e8e913d494fd5a0af524b6f2de (patch)
tree08a1a75440bb50492d07753e6045f15cd93e0555 /.gitlab-ci.yml
parent8e5ffdfafe88a6e7cb52232c80b931be0ce1e5b1 (diff)
downloadm2crypto-09f8808698a4f1e8e913d494fd5a0af524b6f2de.tar.gz
Deprecate Python 3.3 (unsupported by Twisted) and test on 3.7.
Unfortunately 3.7 doesn't work on Travis CI (because of too old OpenSSL).
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml4
1 files changed, 2 insertions, 2 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 64ad083..b899515 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -31,8 +31,8 @@ python34:
- apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted
- python3 setup.py clean build test
-python36:
- image: python:3.6
+python3:
+ image: python:3
when: always
script:
- echo 'deb http://ftp.debian.org/debian jessie-backports main' >/etc/apt/sources.list.d/backports-jessie.list