summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2016-03-14 10:29:53 +0100
committerGitLab <gitlab@gitlab.com>2016-04-20 14:03:50 +0000
commit232eb4d2b38e76f612386c2ea4e22708ad2c8ab5 (patch)
tree35225cafc085d9b7b6498cb249ea6b7ccd91ceb8 /.gitlab-ci.yml
parentba75f65db9c55d45c7a56ea0549d2a91146ee821 (diff)
downloadm2crypto-232eb4d2b38e76f612386c2ea4e22708ad2c8ab5.tar.gz
Multiple stages per test.
Includes python34, CentOS 6 (for Python 2.6), and PyPy.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml66
1 files changed, 56 insertions, 10 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 985269e..ce5cebe 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -1,10 +1,56 @@
-image: python:2.7
-
-test:
- script:
- - apt-get update -q -y
- - apt-get install -y swig libssl-dev libssl1.0.0
- - apt-get install -y python-setuptools
- - easy_install Twisted
- - python setup.py build
- - python setup.py test
+stages:
+ - centos6
+ # - python26
+ - python27
+ - python34
+ - pypy
+
+.python26:
+ stage: python26
+ image: yarara/python-2.6.9:v1
+ when: always
+ script:
+ - python setup.py clean build test
+
+centos6:
+ stage: centos6
+ image: centos:6
+ when: always
+ allow_failure: yes
+ script:
+ - yum upgrade -y
+ - yum install -y swig python-devel openssl-devel openssl python-setuptools python-twisted
+ - python setup.py clean build test
+
+python27:
+ stage: python27
+ image: python:2.7
+ when: always
+ script:
+ - apt-get update -q -y
+ - apt-get install -y swig libssl-dev libssl1.0.0 python-dev openssl python-twisted python-setuptools
+ - python setup.py clean build test
+
+python34:
+ stage: python34
+ image: python:3.4
+ when: always
+ allow_failure: yes
+ script:
+ - apt-get update -q -y
+ - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-twisted python3-setuptools
+ - python3 setup.py clean build test
+
+pypy:
+ stage: pypy
+ image: pypy:2
+ when: always
+ allow_failure: yes
+ script:
+ - if [ \! -f /etc/apt/sources.list.d/jessie-backports.list ] ;
+ echo 'deb http://ftp.debian.org/debian jessie-backports main' > /etc/apt/sources.list.d/jessie-backports.list
+ ; fi
+ - apt-get update -q -y
+ - apt-get install -y swig libssl-dev libssl1.0.0 pypy-dev openssl pypy-setuptools
+ - easy_install Twisted
+ - pypy setup.py clean build test