summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-03-07 22:44:00 +0100
committerMatěj Cepl <mcepl@cepl.eu>2017-03-16 16:46:54 +0100
commit4d4998153f8b19a78eadd9e709b0bd013d6adcbb (patch)
treeb146e5809aa961728bb876fab892b3eaceb10219 /.gitlab-ci.yml
parent9025df3826bbe1ef3ab2f20cd69f9b7ad0ead46b (diff)
downloadm2crypto-4d4998153f8b19a78eadd9e709b0bd013d6adcbb.tar.gz
Add Gitlab CI testing for Python 3.6
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml12
1 files changed, 12 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index e231922..8dc4b8c 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,6 +3,7 @@ stages:
# - python26
- python27
- python34
+ - python36
- fedora
.python26:
@@ -53,6 +54,17 @@ python34:
- easy_install3 Twisted
- python3 setup.py clean build test
+python36:
+ stage: python36
+ image: python:3.6
+ when: always
+ allow_failure: yes
+ script:
+ - apt-get update -q -y
+ - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools
+ - easy_install3 Twisted
+ - python3 setup.py clean build test
+
.pypy:
stage: pypy
image: pypy:2