summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2016-07-25 23:22:52 +0200
committerMatěj Cepl <mcepl@cepl.eu>2016-10-30 20:46:25 +0100
commit55c673dcb3cc740000bb306b8ceb12713221a615 (patch)
tree58935ac6130533d5386634b395e85b3bacaa7213 /.gitlab-ci.yml
parentf54527ea6581ee9342e81cc179d1707c3ac1219a (diff)
downloadm2crypto-55c673dcb3cc740000bb306b8ceb12713221a615.tar.gz
Test also on the latest Fedora image
We cannot use Rawhide, because constant updates are just not working well with GitLab CI.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml11
1 files changed, 11 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index c0d0342..7927dc6 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,6 +3,7 @@ stages:
# - python26
- python27
- python34
+ - fedora
.python26:
stage: python26
@@ -11,6 +12,16 @@ stages:
script:
- python setup.py clean build test
+fedora:
+ stage: fedora
+ image: fedora:latest
+ when: always
+ script:
+ # - dnf upgrade --refresh -y
+ - dnf install -y @development-tools fedora-packager rpmdevtools
+ - dnf install -y swig python-devel openssl-devel openssl python-setuptools python-twisted
+ - python setup.py build test
+
centos6:
stage: centos6
image: centos:6