summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2018-04-12 15:43:48 +0200
committerMatěj Cepl <mcepl@cepl.eu>2018-04-17 10:28:01 +0200
commit6f6bb5189402c1d79ecf9fe0347f813dce1f5ffb (patch)
tree835368e24dad94939c1a03f5e6f44bd297fc8bfa /.gitlab-ci.yml
parentd35d084bb19b33a3ba2a78f304ecca6a6f2827bc (diff)
downloadm2crypto-6f6bb5189402c1d79ecf9fe0347f813dce1f5ffb.tar.gz
Add test on OpenSUSE/Tumbleweed.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml9
1 files changed, 9 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index c29a3a4..ec86c26 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -57,3 +57,12 @@ fedora3:
- dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted
- python3 setup.py clean build test
+
+opensuse:
+ image: opensuse:tumbleweed
+ when: always
+ script:
+ - zypper refresh
+ - zypper install -y pattern:devel_rpm_build pattern:devel_C_C++ osc
+ - zypper install -y swig python3-devel libopenssl1_1 libopenssl-devel python3-setuptools python3-Twisted
+ - python3 setup.py clean build test