summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2018-04-12 15:00:28 +0200
committerMatěj Cepl <mcepl@cepl.eu>2018-04-12 15:10:28 +0200
commit842f2d7e1fea8b7d4ca4f8db9a623e9c4f750d41 (patch)
tree04a107f9a4e5450b6e1d1fb425f6e28deaa2d29f /.gitlab-ci.yml
parent4d380b26e64603202f48c35880328a8f095f0d90 (diff)
downloadm2crypto-842f2d7e1fea8b7d4ca4f8db9a623e9c4f750d41.tar.gz
Don't pull Twisted from pip, use Debian packages from backports.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 1868174..c29a3a4 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -26,18 +26,18 @@ python34:
image: python:3.4
when: always
script:
+ - echo 'deb http://ftp.debian.org/debian jessie-backports main' > /etc/apt/sources.list.d/backports-jessie.list
- apt-get update -q -y
- - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools
- - easy_install3 Twisted
+ - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools python3-twisted
- python3 setup.py clean build test
python36:
image: python:3.6
when: always
script:
+ - echo 'deb http://ftp.debian.org/debian jessie-backports main' >/etc/apt/sources.list.d/backports-jessie.list
- apt-get update -q -y
- - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools
- - easy_install3 Twisted
+ - apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools python3-twisted
- python3 setup.py clean build test
fedora: