summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-10-05 13:37:01 +0200
committerMatěj Cepl <mcepl@cepl.eu>2018-02-08 17:48:50 +0100
commit8956b5e0dc469482a2350b4cac920870badd64a4 (patch)
tree95f8f89ab7e81468d380d727480cba85809e0449 /.gitlab-ci.yml
parente2f707b17273c8998a15a70a3248576457dd4b62 (diff)
downloadm2crypto-8956b5e0dc469482a2350b4cac920870badd64a4.tar.gz
Metadata for py3k port.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml29
1 files changed, 21 insertions, 8 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index d87f28e..956aee3 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -1,11 +1,8 @@
-fedora:
- image: fedora:26
+.python26:
+ image: yarara/python-2.6.9:v1
when: always
script:
- # - dnf upgrade --refresh -y
- - dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- - dnf install -y swig python-devel openssl-devel openssl python-setuptools python-twisted
- - python setup.py build test
+ - python setup.py clean build test
centos6:
image: centos:6
@@ -28,7 +25,6 @@ python27:
python34:
image: python:3.4
when: always
- allow_failure: yes
script:
- apt-get update -q -y
- apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools
@@ -38,9 +34,26 @@ python34:
python36:
image: python:3.6
when: always
- allow_failure: yes
script:
- apt-get update -q -y
- apt-get install -y swig libssl-dev libssl1.0.0 python3-dev openssl python3-setuptools
- easy_install3 Twisted
- python3 setup.py clean build test
+
+fedora:
+ image: fedora:26
+ when: always
+ script:
+ # - dnf upgrade --refresh -y
+ - dnf install --refresh -y @development-tools fedora-packager rpmdevtools
+ - dnf install -y swig python-devel openssl-devel openssl python-setuptools python-twisted
+ - python setup.py build test
+
+fedora3:
+ image: fedora:26
+ when: always
+ script:
+ # - dnf upgrade --refresh -y
+ - dnf install --refresh -y @development-tools fedora-packager rpmdevtools
+ - dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted
+ - python3 setup.py clean build test