summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2016-07-21 17:28:01 +0200
committerMatěj Cepl <mcepl@cepl.eu>2016-07-22 11:35:23 +0200
commita194276bf87cb5420dd53af0eebccd92ac161c1d (patch)
tree738db547055d582a90432fbb667eeccb3cba3629 /.gitlab-ci.yml
parentd29f4a83b4ef542f3fc6f998e7672666e142043d (diff)
downloadm2crypto-a194276bf87cb5420dd53af0eebccd92ac161c1d.tar.gz
Run CentOS 6 tests on Gitlab CI as well.
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml11
1 files changed, 6 insertions, 5 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 8f201f8..c883da2 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -1,5 +1,5 @@
stages:
- # - centos6
+ - centos6
# - python26
- python27
- python34
@@ -11,15 +11,16 @@ stages:
script:
- python setup.py clean build test
-.centos6:
+centos6:
stage: centos6
image: centos:6
when: always
- allow_failure: yes
script:
- yum upgrade -y
- - yum install -y swig python-devel openssl-devel openssl python-setuptools python-twisted
- - python setup.py clean build test
+ - yum groupinstall -y "Development tools"
+ - yum install -y https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
+ - yum install -y swig python-devel openssl-devel openssl python-setuptools python-twisted python-unittest2
+ - python setup.py build test
python27:
stage: python27