summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2021-06-14 23:02:07 +0200
committerMatěj Cepl <mcepl@cepl.eu>2021-06-14 23:02:07 +0200
commit269392d52716a4ef7363dd7dd89ea5d16a9f069c (patch)
treecee5471092e90e00ceaf8652dc05c96897accbe2
parent68592aeb088648c65ea1ac12d9932feb09d7683d (diff)
downloadm2crypto-269392d52716a4ef7363dd7dd89ea5d16a9f069c.tar.gz
New release0.38.0
-rw-r--r--CHANGES13
-rw-r--r--src/M2Crypto/__init__.py2
2 files changed, 14 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 225a365..1b88bb6 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,16 @@
+0.38.0 - 2021-06-14
+-------------------
+
+- Remove the last use of setup.py test idiom.
+- Use m2_PyObject_AsReadBuffer instead of PyObject_AsReadBuffer.
+- Add support for arm64 big endian <Steev Klimaszewski>
+- Make support of RSA_SSLV23_PADDING optional (it has been deprecated).
+- Move project to src/ layout
+- Allow verify_cb_* to be called with ok=True <Casey Deccio>
+- Be prepared if any of constants in x509_vfy.h is not available.
+- But we do support 3.8
+- We DO NOT support Python 2.6.
+
0.37.0 - 2020-12-08
-------------------
diff --git a/src/M2Crypto/__init__.py b/src/M2Crypto/__init__.py
index 4fc489f..88c85b4 100644
--- a/src/M2Crypto/__init__.py
+++ b/src/M2Crypto/__init__.py
@@ -19,7 +19,7 @@ Copyright 2008-2011 Heikki Toivonen. All rights reserved.
"""
# noqa
from distutils.version import StrictVersion
-__version__ = '0.37.1'
+__version__ = '0.38.0'
version = __version__ # type: str
version_info = StrictVersion(__version__).version